Issues logging in

Incident Report for Trakstar Learn

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 17:03 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2025 - 16:31 EDT

Investigating

We're seeing some users experiencing a 503 error when attempting to log into the system or uploading content. Our engineering team is looking into this as we speak!
Posted Jul 28, 2025 - 15:15 EDT
This incident affected: Trakstar Learn (Application).